Du befindest Dich im Archiv vom ABAKUS Online Marketing Forum. Hier kannst Du Dich für das Forum mit den aktuellen Beiträgen registrieren.

Frage zur Onpage optimierung

Hier können Sie Ihre Fragen zum Thema Suchmaschinenoptimierung (SEO) / Positionierung stellen
Neues Thema Antworten
Marco00
PostRank 1
PostRank 1
Beiträge: 13
Registriert: 31.05.2013, 10:23

Beitrag von Marco00 » 20.07.2013, 16:36

Hallo,

ich habe meinen neuen Shop grade mal einem Onpage check unterzogen, und auch mal bei Google site:meinedomain.de eingegeben, und doch ein paar Probleme gefunden.

Fangen wir mal mit site:meinedomain.de an. Laut Webmaster Tools sind von 3029 URL´s 1188 indexiert. Bei Google in der Suche kann ich aber nur 177 finden. Weiteres Problem ist, wenn ich auf die Links klicke, wird fast immer nur die Starseite statt das Produkt angezeigt.

Kann mir einer sagen warum das so ist ?

Dann wird mir ein Fehler ( Auf dem Server nicht vorhandene Seiten liefern einen falschen Status-Code zurück ) angezeigt ( 404-Seite fehlerhaft ). Die URL ist www.meinedomain.de/9b98eb1b ( HTTP-Code 301 ). Klicke ich die URL an, wir die Startseite angezeigt.

Soll ich die URL entfernen oder was muss ich da jetzt machen ?
Fragt sich nur wie ich die finde im Shop ?!

Der W3C Validator zeigt mir auch 22 HTML Fehler an. Meint Ihr dass das zu viele sind ?

Meistens werden folgende Fehler angezeigt:

required attribute "type" not specified

…emplates/_default/frontend/_resources/javascript/jquery-1.7.2.min.js"></script>

The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element.

Typical values for type are type="text/css" for <style> and type="text/javascript" for <script>


character "&" is the first character of a delimiter but occurred as data

sid = (cok && cok[0]) ? cok[0] : null,

This message may appear in several cases:

You tried to include the "<" character in your page: you should escape it as "&lt;"
You used an unescaped ampersand "&": this may be valid in some contexts, but it is recommended to use "&amp;", which is always safe.
Another possibility is that you forgot to close quotes in a previous tag.


document type does not allow element "li" here; missing one of "ul", "ol", "menu", "dir" start-tag

<li>

The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").



Merkwürdig finde ich auch, das bei dem Tool was ich jetzt für die Analyse verwendet habe, folgendes angezeigt wird: Die Seite ist für die indexierung durch Google gesperrt.
Da sind auch alle Kategorien aufgelistet. Aber mein Shop ist ja bei Google.

Könnt Ihr mir sagen was das auf sich hat ?

Vielen Dank schonmal.