Seite 1 von 1

vermutlich htaccess Problem

Verfasst: 02.08.2013, 07:21
von sven415
Hallo, brauche mal Hilfe

Geht um: Atom-strom.de

Die Startseite kann ich aufrufen.

Wenn ich eine Unterseite aufrufe z.b: https://www.atom-strom.de/was-ist-atomstrom.html

geht dies leider nicht.

Die htaccess datei sieht so aus. Das ganze geht seit dem Umzug nicht mehr :(

Code: Alles auswählen

#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.&#40;engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl&#40;\.php&#41;?|xtmpl|svn-base&#41;$|^&#40;code-style\.pl|Entries.*|Repository|Root|Tag|Template|all-wcprops|entries|format&#41;$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Force simple error message for requests for non-existent favicon.ico.
<Files favicon.ico>
  # There is no end quote below, for compatibility with Apache 1.3.
  ErrorDocument 404 "The requested file favicon.ico was not found.
</Files>

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1.
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 4, Apache 2.
<IfModule sapi_apache2.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_value mbstring.encoding_translation   0
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access &#40;A&#41;.
  ExpiresDefault A1209600

  <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
  </FilesMatch>
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option&#58;
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # &#40;http&#58;//example.com/... will be redirected to http&#58;//www.example.com/...&#41;
  # adapt and uncomment the following&#58;
  # RewriteCond %&#123;HTTP_HOST&#125; ^example\.com$ &#91;NC&#93;
  # RewriteRule ^&#40;.*&#41;$ http&#58;//www.example.com/$1 &#91;L,R=301&#93;
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # &#40;http&#58;//www.example.com/... will be redirected to http&#58;//example.com/...&#41;
  # uncomment and adapt the following&#58;
  # RewriteCond %&#123;HTTP_HOST&#125; ^www\.example\.com$ &#91;NC&#93;
  # RewriteRule ^&#40;.*&#41;$ http&#58;//example.com/$1 &#91;L,R=301&#93;

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http&#58;//example.com/drupal uncomment and
  # modify the following line&#58;
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http&#58;//example.com/,
  # uncomment the following line&#58;
  # RewriteBase /

  # Rewrite URLs of the form 'x' to the form 'index.php?q=x'.
  RewriteCond %&#123;REQUEST_FILENAME&#125; !-f
  RewriteCond %&#123;REQUEST_FILENAME&#125; !-d
  RewriteCond %&#123;REQUEST_URI&#125; !=/favicon.ico
  RewriteRule ^&#40;.*&#41;$ index.php?q=$1 &#91;L,QSA&#93;
</IfModule>

# $Id$

Verfasst:
von

Verfasst: 03.08.2013, 11:32
von Kristian
Hast du deinen Hoster schon gefragt, ob mod_rewrite unterstützt wird?

Verfasst: 15.09.2013, 22:41
von mewcrazy
Mit der Standard .htaccess von Drupal sollte dies eigtl. problemlos funktionieren. Wird wie Kristian schon sagte bestimmt wirklich an deaktiviertem mod_rewrite liegen. Du kannst auch mal schauen ob du bei deinem ISP irgendwo in den Einstellungen mod_rewrite aktiveren kannst. (Bei alfahosting bspw. ist es von Standard aus deaktiviert und muss für das jeweilige Hostingpaket bzw. die jeweilige Domain aktiviert werden)