nerd hat geschrieben:ich habe dabei zuerst im cpanel eine umleitung angelegt (daher auch die ersten 2 zeilen), und diese dann nach dem vorhanden muster mit meinen urls erweitert
Und deine .htaccess sieht aus wie die da oben? Keine anderen Einträge? Das ist überaus merkwürdig, vielleicht hilft etwas Stochern im Nebel:
Nimm erstmal alles aus der .htaccess raus. Wenn deine aufgehübschten URLs dann nicht mehr funktionieren (404), stammen die ominösen Weiterleitungen zumindest schonmal mit Sicherheit aus der .htaccess und nicht irgendwo anders her.
Probiere es anschließend mit
nur diesen zwei Zeilen:
RewriteEngine on
RewriteRule ^haarige-susi\.html$ index.php?id=123 [L]
Also als Ziel nur den lokalen Pfad angeben, nicht wie ursprünglich eine komplette URL. Eigentlich müsste mod_rewrite den Host aus deinen RewriteRule-Zeilen von alleine rausnehmen (da Zielhost identisch mit Quellhost) und den Pfad umschreiben anstatt eine Weiterleitung auszuspucken, aber wer weiß …
Bekommst du doch wieder nur eine Weiterleitung, wende dich besser an deinen Hoster.
nachdem meine eigene .htaccess (funktioniert hier unter xaamp wie erwartet) auf dem webhoster jedesmal einen fehler verursacht und eine allgemeine "die seite ist kaputt" seite angezeigt hat.
Fehler in der Serverkonfiguration und damit auch in der .htaccess gehen die Allgemeinheit nichts an; im dümmsten Fall könnte eine ausführlichere Meldung sicherheitsrelevante Details verraten.
Die (halbwegs) genaue Fehlerursache findest du deshalb immer nur im Fehlerprotokoll, das dir dein Hoster zur Verfügung stellen sollte.