Du befindest Dich im Archiv vom ABAKUS Online Marketing Forum. Hier kannst Du Dich für das Forum mit den aktuellen Beiträgen registrieren.

[WP] Adminrechte plötzlich unvöllständig (über Nacht)

Informationen & SEO Tipps zum Einsatz und Verwendung von Blog-, Wiki und Content Management Systemen wie Drupal, Typo3, Wordpress, Reddot, Joomla, Moin Moin, phpWiki sowie Shop-Systemen wie z.B. XT-Commerce, Magento, ePages, Intershop, 1&1 Shops.
Neues Thema Antworten
tided
PostRank 5
PostRank 5
Beiträge: 313
Registriert: 01.08.2010, 13:18

Beitrag von tided » 05.02.2012, 23:01

Hallo zusammen,

ich muss mich seit heute Morgen mit einem ganz kuriosen Problem auseinandersetzen und so langsam glaube ich nichtmehr, dass ich das selbst lösen kann und bitte deshalb um Hilfe von euch.

Scheinbar über Nacht ist dieses Problem entstanden, denn gestern hat alles noch einwandfrei funktioniert:

Als ich mich heute einloggen wollte kam erstmal eine Fehlermeldung namens:

Code: Alles auswählen


Du verfügst nicht über ausreichende Rechte, um auf diese Seite zuzugreifen.
Das Problem konnte ich relativ schnell mit einer Anleitung (https://wordpress.losmuchachos.at/du-has ... trategien/ siehe Punkt 1) beheben. Als Erklärung steht dabei, dass dieses Problem durch ein Update entstehen kann. Ein Update habe ich nicht gemacht, allerdings waren (!) gesten noch 3 Plugin-Aktualisierungen notwendig, welche ich allerdings nicht im Live-System ausführe um solche Fehler zu vermeiden. Warum "waren"? Dazu komme ich gleich.^^

Dann konnte ich mich also schonmal wieder einloggen und war schon super-froh darüber. Allerdings kam dann das nächste Problem, bei welchem ich aktuell auch noch hänge:

Meine Adminrechte wurden mir scheinbar teilweise entzogen. Was ich noch darf ist recht viel: Artikel erstellen und bearbeiten, Plugins installieren, Kommentare von Artikeln freischalten usw. Aber was ich nichtmehr darf ist Seiten bearbeiten und Seiten-Kommentare freischalten und außerdem darf ich gar nicht mehr auf die Benutzerverwaltung zugreifen. Bei dem Punkt wo eigentlich "Benutzer" steht, steht nun nurnoch "Profil". Mehr Rechteentzug hab ich bisher noch nicht feststellen können.

Was noch kurios an der Sache ist, die drei Updates vom Vortag werden nichtmehr angezeigt. Entweder wurden sie druchgeführt, oder aber sie werden nichtmehr erkannt. Updates durch die anderen beiden Admins hat es nicht gegeben und Zugriff auf die Datenbank oder den Server hat außer mir niemand.

In der Datenbank ist bei meinem Usereintrag unter wp_capabilities folgender Eintrag:

Code: Alles auswählen

a:1:{s:13:"administrator";b:1;},
Und auch die anderen 2 Admins haben die neuen eingeschränkten Rechte, also gehe ich davon aus, dass die User-Rolle "administrator" irgendwie die Rechte verändert bekommen hat.

Ist dieses Problem in irgendeiner Weise bekannt? Weiß jemand wie ich aus dieser Misere herauskomme?

Ich hoffe, mir kann jemand helfen. : )

Beste Grüße,
Dennis
Zuletzt geändert von tided am 06.02.2012, 18:11, insgesamt 1-mal geändert.

Anzeige von ABAKUS

von Anzeige von ABAKUS »

SEO Consulting bei ABAKUS Internet Marketing
Erfahrung seit 2002
  • persönliche Betreuung
  • individuelle Beratung
  • kompetente Umsetzung

Jetzt anfragen: 0511 / 300325-0.


dp-wurzel
PostRank 7
PostRank 7
Beiträge: 538
Registriert: 28.02.2007, 18:36

Beitrag von dp-wurzel » 06.02.2012, 09:35

naja das übliche halt...

Alten Datenbankstand wieder einspielen?(oder nur Teile) vorher die alte noch sichern.... Und möglichst schnell die Passwörter ändern. Alle FTP Passwörter etc. ändern. Ich würde auch die Admins degradieren. Wenn man jemand fragt ist es nie irgendwer gewesen :-)

Also mehr würde mir da nicht einfallen... Von dem Problem selbst hab ich noch nie gehört.

tided
PostRank 5
PostRank 5
Beiträge: 313
Registriert: 01.08.2010, 13:18

Beitrag von tided » 06.02.2012, 10:49

Die Ganze DB möcht ich nicht neu einspielen, da seit dem letzten Backup neue Inhalte reinkamen.
Ich probiers heute Abend mal mit den zwei user-Tabellen.

tided
PostRank 5
PostRank 5
Beiträge: 313
Registriert: 01.08.2010, 13:18

Beitrag von tided » 06.02.2012, 18:22

Hat geklappt, habe nun lediglich die "wp_users", die "wp_usermeta" und die "wp_options" aus dem Backup wieder eingespielt.

Danke vielmals für den Tipp dp-wurzel! : )

Antworten