Du befindest Dich im Archiv vom ABAKUS Online Marketing Forum. Hier kannst Du Dich für das Forum mit den aktuellen Beiträgen registrieren.

Verzeichnisse eliminieren

Mehrere Domains, Domain-Umzug, neue Dateinamen, 301/302
Neues Thema Antworten
msuess
PostRank 8
PostRank 8
Beiträge: 697
Registriert: 02.04.2005, 12:27

Beitrag von msuess » 25.09.2013, 06:16

Ich wage mich an die Änderung von Permalinks bei WP-Instanzen, die ich seit 7 oder 8 Jahren nicht angefasst habe.

Aktuell schaut das Muster wie folgt aus:

domain.de/slug/category/titel.html

Ich möchte aber haben:

domain.de/titel.html

Und dachte mir, die folgende Zeile in .htaccess sollte das Problem beheben:

RewriteRule ^/static-slug/(.*)/$ /$ [R=301,L]

Tut es nicht. Wo liegt mein Fehler?

swiat
PostRank 10
PostRank 10
Beiträge: 6202
Registriert: 25.02.2005, 23:56

Beitrag von swiat » 25.09.2013, 20:30

Gabs oder gibts dafür kein Plugin?

Vielleicht hilft das weiter, sollte doch änderbar sein ohne das man was in die .htaccess schreibt.

https://ideecon.com/wordpress-3-x-permal ... ndern/1652

Gruss
Kostenlose Backlinks: Hier lang <<<

msuess
PostRank 8
PostRank 8
Beiträge: 697
Registriert: 02.04.2005, 12:27

Beitrag von msuess » 25.09.2013, 20:55

Das war sehr hilfreich!

Thomas B.
PostRank 4
PostRank 4
Beiträge: 137
Registriert: 11.09.2013, 21:04
Wohnort: München

Beitrag von Thomas B. » 25.09.2013, 21:03

msuess hat geschrieben:...

RewriteRule ^/static-slug/(.*)/$ /$ [R=301,L]

Tut es nicht. Wo liegt mein Fehler?
Deine Url endet mit .html (domain.de/slug/category/titel.html) deine RewriteRule prüft auf einem Slash (/) am Ende der URL. Und die Weiterleitung geht auf $ im Root Verzeichnis der Domain.

msuess
PostRank 8
PostRank 8
Beiträge: 697
Registriert: 02.04.2005, 12:27

Beitrag von msuess » 25.09.2013, 21:16

Das funktioniert nun.

RedirectMatch 301 ^/static-slug/([^/]+)/([^/]+).html$ https://www.domain.de/$2

jhansen
PostRank 2
PostRank 2
Beiträge: 39
Registriert: 31.12.2007, 22:37

Beitrag von jhansen » 10.12.2013, 08:38

msuess; ich habe das gleiche vor und auch eine fast ähnliche Struktur mit .html. Hast du die Permalink-Settings im Wordpress dann aber auch geändert oder?

Und hast du die ganzen internen Links auf deiner Seite geändert auf die neue Seite oder hast du das durch den 301 Redirect dann einfach so gelassen?

Gruß

msuess
PostRank 8
PostRank 8
Beiträge: 697
Registriert: 02.04.2005, 12:27

Beitrag von msuess » 10.12.2013, 10:18

Ich habe die Einstellungen im WP Backend natürlich auch entsprechend geändert.

Antworten